Back to overview
Downtime

Major Service Outage - Upstream Provider Issue

Nov 18 at 08:19am EST
Affected services
Forms
Portal
Widgets

Resolved
Nov 18 at 10:01am EST

Service Restored - Connectivity Issues Resolved

The upstream issue with our service provider, Cloudflare, has been resolved. We have verified that Testimonial iQ services are fully operational and all systems are back to normal.

We will continue to monitor performance closely over the next few hours. If you are still experiencing issues, please try clearing your browser cache or refreshing the page.

Created
Nov 18 at 08:19am EST

Testimonial iQ services are currently unavailable due to a major outage affecting Cloudflare, which powers our network infrastructure. This is impacting our ability to serve traffic to users globally.

We are strictly monitoring Cloudflare's resolution progress and will restore full service immediately once their systems are operational.

You can view Cloudflare's status directly here: https://www.cloudflarestatus.com/